Changes to Modules on 9th August 2017

A number of changes are planned to modules on the system during the maintenance session on 9th August 2017.

If you have any questions or comments about the planned changes then please contact the ARCHER Helpdesk.

Change in default system software modules

You can preview these changes to the system modules by using the command:

module load cdt/17.05

Once the defaults have changed, you can return to the current system module defaults with the command:

module load cdt/15.11

The following module defaults will change:

atp                         1.8.3 => 2.1.0
cce                         8.4.1 => 8.5.8
cray-ccdb                   1.0.7 => 2.0.3
cray-ga                   5.3.0.4 => 5.3.0.7
cray-hdf5                  1.8.14 => 1.10.1
cray-hdf5-parallel         1.8.14 => 1.10.1
cray-lgdb                   2.4.5 => 3.0.6
cray-libsci                13.2.0 => 16.11.1
cray-mpich                  7.2.6 => 7.5.5
cray-mpich-abi              7.2.6 => 7.5.5
cray-netcdf               4.3.3.1 => 4.4.1.1
cray-netcdf-hdf5parallel  4.3.3.1 => 4.4.1.1
cray-petsc                3.6.1.0 => 3.7.5.0
cray-petsc-64             3.6.1.0 => 3.7.5.0
cray-petsc-complex        3.6.1.0 => 3.7.5.0
cray-petsc-complex-64     3.6.1.0 => 3.7.5.0
craypkg-gen                 1.3.2 => 1.3.5
cray-shmem                  7.2.6 => 7.5.5
cray-tpsl                   1.5.2 => 17.04.1
cray-tpsl-64                1.5.2 => 17.04.1
cray-trilinos           11.12.1.5 => 12.8.1.0
craype                      2.4.2 => 2.5.10
fftw                      3.3.4.5 => 3.3.4.11
gcc                         5.1.0 => 6.3.0
intel                  15.0.2.164 => 17.0.0.098
iobuf                       2.0.6 => 2.0.8
modules                  3.2.10.2 => 3.2.10.6
papi                      5.4.1.2 => 5.5.1.1
perftools                   6.3.0 => 6.4.6
perftools-base              6.3.0 => 6.4.6
perftools-lite              6.3.0 => 6.4.6
stat                      2.2.0.1 => 2.2.0.4 

Change in default scientific software modules

The following module defaults will change:

allinea                   6.1.2 => 7.0
anaconda          2.2.0-python2 => python2
anaconda-compute  2.2.0-python2 => python2
bison                     2.6.5 => 3.0.4
boost                      1.55 => 1.60
boost-serial               1.55 => 1.60
castep                    8.0.0 => 17.2.1-gcc6
castep-serial             8.0.0 => 17.2.1-intel15
cmake                    2.8.12 => 3.5.2
cp2k                  4.1.17463 => 5.0.17657
cube                        4.3 => 4.3.5
dlmeso                      2.5 => 2.6
espresso              5.0.3-mkl => 5.4.0-mkl
fds                       6.3.2 => 6.4.0
gpaw-setups           0.9.11271 => 0.9.20000
gromacs                     5.1 => 2016.3
gsl                         1.9 => 1.16
lammps           lammps-11Nov13 => lammps-17Nov16
leave_time                1.0.0 => 1.3.0
libxc              2.1.0-build2 => 3.0.0
mesa                     10.0.4 => 17.1.0
namd                        2.9 => 2.12
ncl                       6.1.2 => 6.4.0
octopus            4.1.2-build2 => 6.0-build1
onetep                      4.3 => 4.4.4
paraview                  4.1.0 => 5.2.0
scalasca                    2.2 => 2.3.1
scorep                      1.4 => 3.1
siesta                      3.2 => 4.1
svn                       1.8.9 => 1.8.10
tecplot                    2013 => 2016
vasp5                     5.4.1 => 5.4.4-intel16
wien2k                     13.1 => 14.2